ARIS Community - We Love BPM

Aris 9.8 Installation Issues

espmsul's picture
by Fernando Gorgen Radici in University Relations posted on 2016-11-08

Hello everyone,

I'm trying to install Aris 9.8 Design server but the installation process take to much time to end (about 20 hours), it gets stucked on "Step 2 of 13 db runnables are being installed" and returned the error message: "Errors occurred during the installation process. Unable to install."  I followed the steps described in installation guide and runned the setup file as administrator. 

If anyone can help, i'll be very thankfull?

The log file contents are bellow:

2016-11-07 14:38:41 Debug OnSetUpdateMode
2016-11-07 14:38:50 Setup start ######################################################################################################
2016-11-07 14:38:59 Dialog : Dlg_SdWelcome
2016-11-07 14:39:10 Dialog : Dlg_SdLicenseEx
2016-11-07 14:39:12 Dialog : PARAM_Dlg_Select_Edit-REMOTE-URL
2016-11-07 14:39:37 Dialog : remote.Install.URL localhost
2016-11-07 14:39:37 Dialog : remote.b.Install FALSE
2016-11-07 14:39:37 Dialog :  
2016-11-07 14:39:37 Dialog :  
2016-11-07 14:39:37 Dialog :  
2016-11-07 14:39:37 Dialog : remote.PW *
2016-11-07 14:39:37 command :list
2016-11-07 14:41:42  stderr: Unable to add node localhost to ensemble. 
2016-11-07 14:41:42  stderr: Could not connect to http://localhost:9001/rest. Make sure that an agent is running on this machine and that the specified port is correct. Also check if you used the right protocol to communicate with the agent (you used HTTP, try HTTPS). 
2016-11-07 14:41:44 Dialog : Dlg_SdAskDestPath_LocalDrive
2016-11-07 14:41:49 Dialog : PARAM_Dlg_SdShowDlgEdit_Enable-ExternalIP
2016-11-07 14:41:55 Dialog : SERVER.ExternalIP.active 
2016-11-07 14:41:55 Dialog : Loadbalancer.HTTPD.servername 
2016-11-07 14:41:55 Dialog :  
2016-11-07 14:41:55 Dialog :  
2016-11-07 14:41:56 Dialog : PARAM_Dlg_SdShowDlgEdit_Enable-CHANGECURRENTUSER
2016-11-07 14:42:50 Dialog : AGENT.CHANGE.active TRUE
2016-11-07 14:42:50 Dialog : AGENT.CHANGE.USER ESPM
2016-11-07 14:42:50 Dialog : AGENT.CHANGE.password *****
2016-11-07 14:42:50 Dialog :  
2016-11-07 14:42:50 Dialog :  
2016-11-07 14:42:51 Dialog : PARAM_Dlg_SdShowDlgEdit_Select-HTTP_PORT
2016-11-07 14:43:44 Dialog : Loadbalancer.HTTPD.port 1080
2016-11-07 14:43:44 Dialog : Sd_Http_PORT_select_.checked TRUE
2016-11-07 14:43:44 Dialog : Loadbalancer.HTTPD.ssl.port 443
2016-11-07 14:43:44 Dialog : Sd_Https_PORT.checked 
2016-11-07 14:43:44 Dialog :  
2016-11-07 14:43:44 Dialog : .checked 
2016-11-07 14:43:44 Dialog :  
2016-11-07 14:43:44 Dialog : .checked 
2016-11-07 14:43:45 Dialog : PARAM_Dlg_SdMemoryType-MEMORY
2016-11-07 14:43:51 Dialog : memory.modell l
2016-11-07 14:43:51 Dialog : PARAM_Dlg_SdLicChooser
2016-11-07 14:44:05 Dialog : lic.select TRUE
2016-11-07 14:44:05 Dialog : lic.source E:\AEP multi for faculty.zip
2016-11-07 14:44:06 Dialog : Dlg_BP_DB_System
2016-11-07 14:44:10 Dialog : PARAM_Dlg_SMTP_SERVER
2016-11-07 14:44:17 Dialog : SERVER.MAILSERVER.active FALSE
2016-11-07 14:44:17 Dialog : SERVER.smtp.host 
2016-11-07 14:44:17 Dialog : SERVER.smtp.port 
2016-11-07 14:44:17 Dialog : SERVER.smtp.mailerid 
2016-11-07 14:44:17 Dialog : SERVER.smtp.account 
2016-11-07 14:44:17 Dialog : SERVER.smtp.password *****
2016-11-07 14:44:17 Dialog : SERVER.smtp.crypt FALSE
2016-11-07 14:44:18 Dialog : PARAM_Dlg_SdShowDlgEdit_Enable-PROXY
2016-11-07 14:44:21 Dialog : SERVER.PROXY.active 
2016-11-07 14:44:21 Dialog : SERVER.PROXY.host 
2016-11-07 14:44:21 Dialog : SERVER.PROXY.port 
2016-11-07 14:44:21 Dialog : SERVER.PROXY.account 
2016-11-07 14:44:21 Dialog : SERVER.PROXY.password *****
2016-11-07 14:44:21 Dialog :  
2016-11-07 14:44:21 Dialog :  
2016-11-07 14:44:22 Dialog : PARAM_Dlg_Radio_Options_2-STARTMODUS
2016-11-07 14:44:25 Dialog : start.AUTO_START TRUE
2016-11-07 14:44:25 Dialog : start.MANUAL_START FALSE
2016-11-07 14:44:27 Dialog : Dlg_SdStartCopy
2016-11-07 14:44:33 ###### START ####IDS_Get_Runable_run_Status######
2016-11-07 14:44:33 # command : list 
2016-11-07 14:46:37 #  stderr: Unable to add node localhost to ensemble. 
2016-11-07 14:46:37 #  stderr: Could not connect to http://localhost:9001/rest. Make sure that an agent is running on this machine and that the specified port is correct. Also check if you used the right protocol to communicate with the agent (you used HTTP, try HTTPS). 
2016-11-07 14:46:37 # ###### END ####IDS_Get_Runable_run_Status######
2016-11-07 14:46:37 command : stopall 
2016-11-07 14:48:41  stderr: Unable to add node localhost to ensemble. 
2016-11-07 14:48:41  stderr: Could not connect to http://localhost:9001/rest. Make sure that an agent is running on this machine and that the specified port is correct. Also check if you used the right protocol to communicate with the agent (you used HTTP, try HTTPS). 
2016-11-07 14:48:41 command : quick killall 
2016-11-07 14:50:45  stderr: Unable to add node localhost to ensemble. 
2016-11-07 14:50:45  stderr: Could not connect to http://localhost:9001/rest. Make sure that an agent is running on this machine and that the specified port is correct. Also check if you used the right protocol to communicate with the agent (you used HTTP, try HTTPS). 
2016-11-07 14:51:22 CMDLINE : addon "TARGETDIR=C:\SoftwareAG\ARIS9.8"
2016-11-07 14:51:22 UPDATEMODE : FALSE
2016-11-07 14:51:22 This is a virtual machine. Type: VMware product such as VMware Player, VMware Workstation, or VMware Server
2016-11-07 14:51:22 EXTENDEDMEMORY: 8388152 K
2016-11-07 14:52:25 registry: type S KeyName PATH Value C:\SoftwareAG\ARIS9.8
2016-11-07 14:52:25 registry: type S KeyName Version Value 98.5.0.1091879
2016-11-07 14:52:25 registry: type S KeyName Codeline Value //ALL/rel/9.8/98.5.0
2016-11-07 14:52:25 registry: type S KeyName ARISHOME Value C:\SoftwareAG\ARIS9.8\server
2016-11-07 14:52:26  exitcode 2 net start ARISCloudAgent
2016-11-07 14:52:26 ###### START ####Check whether ARIS Agent is running.######
2016-11-07 14:52:26 # command : list
2016-11-07 14:54:29 #  stdout: 
2016-11-07 14:54:29 #  stdout: On node localhost 0 runnables are installed.
2016-11-07 14:54:29 #  list
2016-11-07 14:54:31 # ###### END ####Check whether ARIS Agent is running.######
2016-11-07 14:54:31 command : -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{115B0818-894A-4049-BBA9-0855D9808433}\{7B3B41FD-F2F8-4C36-8C4A-89F98B3E3601}\set_by.pt
2016-11-07 14:56:34  stdout: 
2016-11-07 14:56:34  stdout: Executing command "set installed.by="ARIS Agent setup;1091879;98.5.0.1091879""
2016-11-07 14:56:34  stdout: Successfully set configuration parameter installed.by to ARIS Agent setup;1091879;98.5.0.1091879 on node localhost
2016-11-07 14:56:34   script: 
2016-11-07 14:56:34   script Length: 0  
2016-11-07 14:56:56 ###### START ####Check whether ARIS Agent is running.######
2016-11-07 14:56:56 # command : list
2016-11-07 14:58:59 #  stdout: 
2016-11-07 14:58:59 #  stdout: On node localhost 0 runnables are installed.
2016-11-07 14:58:59 #  list
2016-11-07 14:59:01 # ###### END ####Check whether ARIS Agent is running.######
2016-11-07 14:59:01 command :get agent.version
2016-11-07 15:01:04  stdout: 
2016-11-07 15:01:04  stdout: On node agent.version:
2016-11-07 15:01:04  stdout: "98.5.0.1091879"
2016-11-07 15:01:04   script: 
2016-11-07 15:01:04   script Length: 0  
2016-11-07 15:01:09 webserver :  install vcredist_2010_x86.exe 
2016-11-07 15:01:35 webserver :  LAUNCHED  Port: 13131 PATH: C:\Users\FERNAN~1\AppData\Local\Temp\2\aris_install_http_server_20161107143850
2016-11-07 15:01:35 command : set autostart.mode=off
2016-11-07 15:03:38  stdout: 
2016-11-07 15:03:38  stdout: Successfully set configuration parameter autostart.mode to off on node localhost
2016-11-07 15:03:38 command : set local.repository.only=FALSE
2016-11-07 15:06:41  stdout: 
2016-11-07 15:06:41  stdout: Successfully set configuration parameter local.repository.only to FALSE on node localhost
2016-11-07 15:06:41 command :list 
2016-11-07 15:09:44  stdout: 
2016-11-07 15:09:44  stdout: On node localhost 0 runnables are installed.
2016-11-07 15:09:44 command : set local.repository.only=FALSE
2016-11-07 15:12:47  stdout: 
2016-11-07 15:12:47  stdout: Successfully set configuration parameter local.repository.only to FALSE on node localhost
2016-11-07 15:12:47 command : -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\repository_url.pt
2016-11-07 15:15:50  stdout: 
2016-11-07 15:15:50  stdout: Executing command "set remote.repository.url="http://localhost:13131/repo""
2016-11-07 15:15:50  stdout: Successfully set configuration parameter remote.repository.url to http://localhost:13131/repo on node localhost
2016-11-07 15:15:50   script: set remote.repository.url="http://localhost:13131/repo"
2016-11-07 15:15:50 ###### START ####IDS_Get_Runable_run_Status######
2016-11-07 15:15:51 # command : list 
2016-11-07 15:18:54 #  stdout: 
2016-11-07 15:18:54 #  stdout: On node localhost 0 runnables are installed.
2016-11-07 15:18:54 # ###### END ####IDS_Get_Runable_run_Status######
2016-11-07 15:18:54 command : stopall 
2016-11-07 15:21:57  stdout: 
2016-11-07 15:21:57  stdout: Successfully stopped all not-yet running runnables on localhost.
2016-11-07 15:21:57 command : quick killall 
2016-11-07 15:25:00  stdout: 
2016-11-07 15:25:00  stdout: All runnables on localhost have been killed.
2016-11-07 15:25:00 command :-f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\configure.pt -c "E:\ARIS_DVD-98.5.0.1091879\Setups\Windows\ARIS_Design_Server\generated.apptypes.cfg"
2016-11-07 15:28:07  stdout: 
2016-11-07 15:28:07  stdout: Executing command "configure zoo_l zoo_l tickTime="60000""
2016-11-07 15:28:07  stdout: Successfully configured runnable zoo_l on node localhost.
2016-11-07 15:28:07   script: configure zoo_l zoo_l tickTime="60000"
2016-11-07 15:28:07 command :-f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\configure.pt -c "E:\ARIS_DVD-98.5.0.1091879\Setups\Windows\ARIS_Design_Server\generated.apptypes.cfg"
2016-11-07 19:28:07  stdout: 
2016-11-07 19:28:07  stdout: Executing command "configure postgres_l postgres_l"
2016-11-07 19:28:07  stderr: Error at line 1 of file C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\configure.pt: 
2016-11-07 19:28:07  stderr: Unable to configure runnable postgres_l on node localhost.
2016-11-07 19:28:07  stderr: Could not configure runnable postgres_l (com.aris.runnables.PostgreSQL-run-prod-98.5.0) on node localhost: Ant configure exited with 1
2016-11-07 19:28:07 error : exitcode 1 -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\configure.pt -c "E:\ARIS_DVD-98.5.0.1091879\Setups\Windows\ARIS_Design_Server\generated.apptypes.cfg"
2016-11-08 09:57:48   script: configure postgres_l postgres_l 
2016-11-08 09:57:48  CopyFileE:\ARIS_DVD-98.5.0.1091879\Setups\Windows\ARIS_Design_Server\generated.apptypes.cfg to C:\SoftwareAG\ARIS9.8\server\generated.apptypes.cfg
2016-11-08 09:57:48 ###### START ####Gathering information about components in use...######
2016-11-08 09:57:48 # command :list
2016-11-08 09:59:53 #  stdout: 
2016-11-08 09:59:53 #  stdout: On node localhost 1 runnables are installed.
2016-11-08 09:59:53 #  stdout: zoo_l : [31mSTOPPED[0m (com.aris.runnables.zookeeper-run-prod-98.5.0)
2016-11-08 09:59:53 # ###### END ####Gathering information about components in use...######
2016-11-08 09:59:53 registry: type S KeyName ProgramGroup Value ARIS
2016-11-08 09:59:56 command : startall to umcadmin_l
2016-11-08 10:01:59  stdout: 
2016-11-08 10:01:59  stdout: Could not start all runnables on  node localhost.
2016-11-08 10:01:59  stdout: A runnable with ID umcadmin_l is not configured
2016-11-08 10:01:59 error : exitcode 102  startall to umcadmin_l
2016-11-08 10:01:59 command : wait for started umcadmin_l timeout 300000
2016-11-08 10:05:02  stdout: 
2016-11-08 10:05:02  stdout: Could not read state of runnable umcadmin_l on node localhost: Runnable instance ID "umcadmin_l" does not exist.
2016-11-08 10:05:02 error : exitcode 1  wait for started umcadmin_l timeout 300000
2016-11-08 10:05:02 command : -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\enhancements.tp
2016-11-08 10:08:05  stdout: 
2016-11-08 10:08:05  stdout: Executing command "set remote.repository.url="http://localhost:13131""
2016-11-08 10:08:05  stdout: Successfully set configuration parameter remote.repository.url to http://localhost:13131 on node localhost
2016-11-08 10:08:05  stdout: Executing command "enhance umcadmin_l with importLicense path  "lic/lic.zip" options tenant.name=default"
2016-11-08 10:08:05  stderr: Error at line 2 of file C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\enhancements.tp: 
2016-11-08 10:08:05  stderr: Enhancement Enhancement importLicense lic/lic.zip {tenant.name=[default]} failed: A runnable with ID umcadmin_l is not configured
2016-11-08 10:08:05 error : exitcode 1  -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\enhancements.tp
2016-11-08 10:08:05   script: 
2016-11-08 10:08:05   script Length: 0  
2016-11-08 10:08:05 command : -f C:\Users\FERNAN~1\AppData\Local\Temp\2\{47274E54-C04A-4C09-A3F6-C8837E49CC2E}\{38371DF8-9A98-4380-AA90-44A9DE9E5FA2}\user.txt
2016-11-08 10:11:08  stdout: 
2016-11-08 10:11:08  stdout: Executing command "set username=********
2016-11-08 10:11:08  stdout: Successfully set configuration parameter username to ***********************
2016-11-08 10:11:08  stdout: The change of this configuration parameter requires a restart of the agent on node localhost to become effective.
2016-11-08 10:11:08  stdout: Executing command "set password=***********
2016-11-08 10:11:08  stdout: Successfully set configuration parameter password ******************************
2016-11-08 10:11:08  stdout: The change of this configuration parameter requires a restart of the agent on node localhost to become effective.
2016-11-08 10:11:08 command : restart agent
2016-11-08 10:14:11  stdout: 
2016-11-08 10:14:11  stdout: Successfully triggered restart of the agent on node localhost.
2016-11-08 10:14:11 ###### START ####Check whether ARIS Agent is running.######
2016-11-08 10:14:11 # command : list
2016-11-08 10:17:14 #  stdout: 
2016-11-08 10:17:14 #  stdout: On node localhost 1 runnables are installed.
2016-11-08 10:17:14 #  stdout: zoo_l : [31mSTOPPED[0m (com.aris.runnables.zookeeper-run-prod-98.5.0)
2016-11-08 10:17:14 #  list
2016-11-08 10:17:16 # ###### END ####Check whether ARIS Agent is running.######
2016-11-08 10:17:17 Dialog : SdFinish szMsg1: Errors occurred during the installation process. Unable to install. For further information please refer to file '%temp%/ARIS_Install.log'.
 

10204 Views
0 Likes
9 Comments
Sorry there are no tags
There are no attachments
Tony Iliev posted on 2016-11-16

Hi Fernando,

I assume that you use Windows installation. Did you install the ARIS Agent (and ensure it is started) prior the ARIS Connect installation?

Regards
Tony

Fernando Gorgen Radici posted on 2016-11-16

Hi Tony,

I forgot to mention, yes my system is a Windows Server 2008R2.The ArisCloudAgent is installed and set to automatic in the startup type, on Windows Services.

Should I install the Aris Agent before install the Aris Design Server? I don't see this information in the documentation. 

Thank you for reply

Rune Becker posted on 2016-11-16

Olá Fernando,

As you have chosen the "l" sizing, did you check that your computer meets the hardware requirements?

From the license file name I'd guess you are installing the ARIS university edition.

Is drive E: a CD/DVD drive or a (slow?) USB stick?

Cheers
Rune

Fernando Gorgen Radici posted on 2016-11-16

Hi Rune,

Yes, I'm using the ARIS University edition (one more thing I forget to mention) .I followed the hardware requirements for Aris Design Server (8GB RAM - 2-4 CPU - 2GB Free HD Space) on my virtual machine.

I started the installation process from files extracted from the ISO file, so I don't used any pendrive or DVD drive.

Thank you for reply

Rune Becker posted on 2016-11-17

Sorry, but these hardware figures you have misinterpreted. ARIS Client is fine with 2 GB free hard disk space when you install ARIS Architect without its own database system. Means, you have then to work with another ARIS Design Server. But if you install Architect (ARIS Client) with its local database system you need >=20 GB free disk space. See Platform Matrix. And all that counts only for "S" (Demo) sizing, the smallest sizing. But according to your ARIS_Install.log you have chosen "L" (Large)  where 24/32 GB are needed/recommended along with 12/16 CPUs.

Fernando Gorgen Radici posted on 2016-11-17

So I'll need a virtual machine with requirements for "L" (Large), about 24/32 GB hard disk free space and 12/16 CPU. About the RAM, how much will I need?

Rune Becker posted on 2016-11-18

No, you don't need such a huge machine, unless your ARIS team would be very large. How many users are planned to use your ARIS installation?

Most universities are installing "M" (medium).

Cheers
Rune

Fernando Gorgen Radici posted on 2016-11-22

Hi Rune,

Sorry for the delay to answer. I talked to the professor who is in charge of Aris and I will install the "M" installation, for about 25 to 30 users.

Thanks for reply again

Fernando Gorgen Radici posted on 2017-01-23

Hello again everyone,

Just for reply about the solution of my case. 

I started changing the amount o RAM (from 8 to 16 GB). Later, I started a several times the installation process without success. After that, I created a new virtual machine with 16GB RAM, 4 Cores CPU, 80 GB HD and Windows Server 2012 R2 Standard edition, and everything worked fine like should to be. My guess is, there is another process in the old server, and it is blocking the installation.

Thank you all for reply