Profile picture for user pamillet

hello,

a problem with client acces to ARIS Server in the AEP-PDA VM...

ARIS is working using ARIS client, the Apache server is OK, the ARIS server service is running...

but when starting the ARIS web client, i have the error

------------

2013-10-03T17:20:14,100 INFO - [server access] retrieving server connection data

2013-10-03T17:20:14,101 INFO - [server access] - appserver : URAEPPDAW764.eur.ad.sag

2013-10-03T17:20:14,101 INFO - [server access] - port      : 16070

2013-10-03T17:20:14,101 INFO - [server access] - SSL port  : 0

2013-10-03T17:20:14,101 INFO - [server access] - use SSL   : false

2013-10-03T17:20:14,101 INFO - [server access] - use Tunnel   : false

2013-10-03T17:20:14,102 INFO - [server access] starting client profile ...

2013-10-03T17:20:14,756 INFO - [server access] could not connect to server: URAEPPDAW764.eur.ad.sag

2013-10-03T17:20:14,756 INFO -

2013-10-03T17:20:14,756 INFO - Starting diagnostics procedure:

2013-10-03T17:20:14,787 INFO - ERROR: Unknown hostname ...



----------------

and i can't connect to ARIS site administrator...

I've change the name of the VM to install it on a VM server... ?

 

Where can i set the correct server name ??

 

thanks in advance

 

regards

pam

 

by Pierre-Alain MILLET Author
Posted on Thu, 10/03/2013 - 17:27

sorry for the error in the title of this post... the keyword is faster than my fingers...

ARIS server name in AEP PDA Package..

;-o)

 

pam

0
by Pierre-Alain MILLET Author
Posted on Tue, 10/08/2013 - 11:15

An answer and a new question...

this first issue was a windows one.. In fact, something strange in this windows version... The services "ARIS Business Server" seems "started" in the services list, but when i select it and display its property, it's in fact stopped...

See the screen copy. below

And After starting the services, ARIS server is OK

But, and that is my new question...  when starting a web client, the ARIS appli start, but with non connection to the server. When i "add a server", using test mode, i have the folowing log

2013-10-08T11:12:41,702 INFO - [server access] connecting server ...

2013-10-08T11:12:41,702 INFO -

2013-10-08T11:12:41,702 INFO - [server access] retrieving server connection data

2013-10-08T11:12:41,702 INFO - [server access] - appserver : localhost

2013-10-08T11:12:41,702 INFO - [server access] - port      : 16070

2013-10-08T11:12:41,702 INFO - [server access] - SSL port  : 443

2013-10-08T11:12:41,702 INFO - [server access] - use SSL   : false

2013-10-08T11:12:41,702 INFO - [server access] - use Tunnel   : false

2013-10-08T11:12:41,702 INFO - [server access] starting client profile ...

2013-10-08T11:12:41,702 INFO - [server access] looking for server dispatcher ...

2013-10-08T11:12:41,717 INFO - [server access] could not connect to server: localhost

2013-10-08T11:12:41,717 INFO -

2013-10-08T11:12:41,717 INFO - Starting diagnostics procedure:

2013-10-08T11:12:41,717 INFO - ARIS Site at localhost:16070 available ...

2013-10-08T11:12:41,717 INFO - ERROR: User or password wrong ...

??? At this step, i do not see what is this password in error...

And, if i try to acces to ARIS Site administator, I have the following error... 'unable to generate database list for the "arisserver" server.. ?? I'v tried to regenerate html without change

hum... I re read the installation documentation without ideas...

thanks a lot if one can help

best regards

pam

 

0
by Pierre-Alain MILLET Author
Posted on Tue, 10/08/2013 - 16:00

New step in my work to obtain a running installation of ARIS business server

the more detailed sutation :

- the ARIS Business server is started but do not answer to  Web client

- the pubnlic port in defaultserverconfig is 16070 and is not modified in userserverconfig

- but this port is not in the netstat list...  .

So, the ARIS Business server is started, but do not listen to the 16070 port....

??????????

do i have to reinstall  ?!

regards

pam

if the ARIS cloud solution is open to academic partner, i'll be the firts candidate !

 

0
by Kai-Hendrik Pots
Posted on Wed, 10/09/2013 - 13:10

Hello pam,

seems the Business Server has got some Problems. Can you post the server0.log from the ARIS Business Server (Path: C:\SoftwareAg\ARIS7.2\server\log\server0.log).

Best Regards

Kai-Hendrik

0
by Pierre-Alain MILLET Author
Posted on Wed, 10/09/2013 - 15:33

hereabove,

but the situation has changed...

the issue regarding services and port is solved. It was the hots files, that i'd changed which was non readable..

now the ARIS BS service is running, and the port 16070 is open...

 

but the two error messages are still here

- when running Site administator, using localhost 16073 SITEADMIN, i have the error "impossible to generate database list"

- when running the ARIS BA web client, no server are active with the following error in java log 

<hr>

2013-10-09T15:23:25,575 INFO - [server access] retrieving server connection data

2013-10-09T15:23:25,575 INFO - [server access] - appserver : 134.214.106.18

2013-10-09T15:23:25,575 INFO - [server access] - port      : 16070

2013-10-09T15:23:25,575 INFO - [server access] - SSL port  : 443

2013-10-09T15:23:25,575 INFO - [server access] - use SSL   : false

2013-10-09T15:23:25,575 INFO - [server access] - use Tunnel   : false

2013-10-09T15:23:25,575 INFO - [server access] starting client profile ...

2013-10-09T15:23:25,575 INFO - [server access] looking for server dispatcher ...

2013-10-09T15:23:25,575 INFO - [server access] could not connect to server: 134.214.106.18

2013-10-09T15:23:25,575 INFO -

2013-10-09T15:23:25,575 INFO - Starting diagnostics procedure:

2013-10-09T15:23:25,575 INFO - ARIS Site at 134.214.106.18:16070 available ...

2013-10-09T15:23:25,575 INFO - ERROR: User or password wrong ...

2013-10-09T15:23:25,575 INFO -

<hr>

It seems to have an error with Sqlserver... It's new to use SQLSever for ADP ?

the server0.log

<hr>

2013-10-09T15:20:25,558 [ ARIS Server Startup process ]

2013-10-09T15:20:25,558

2013-10-09T15:20:25,589 supported oem profile: ARIS

2013-10-09T15:20:25,589

2013-10-09T15:20:25,589

2013-10-09T15:20:25,792 Started profile Public@16070

2013-10-09T15:20:25,792 Started profile Private@16071

2013-10-09T15:20:25,808

2013-10-09T15:20:25,808 Starting ARIS Nameservice 7.2.4.746019(7.1.0.746019)(Public)

2013-10-09T15:20:25,824

2013-10-09T15:20:25,824 Starting ARIS Event Service 7.2.4.746019(7.1.0.746019)(Private)

2013-10-09T15:20:25,839

2013-10-09T15:20:25,839 Starting ARIS Nameservice 7.2.4.746019(7.1.0.746019)(Private)

2013-10-09T15:20:25,839

2013-10-09T15:20:25,839 Starting DB event initialisation 7.2.4.746019(7.1.0.746019)(Private)

2013-10-09T15:20:25,871 - event channel is created

2013-10-09T15:20:25,886

2013-10-09T15:20:25,886 Starting ARIS Lockservice 7.2.4.746019(7.1.0.746019)(Private)

2013-10-09T15:20:27,636 - using mapping 'com.idsscheer.dl.mapimpl.mssql.AMapping'

2013-10-09T15:20:27,714 - using url 'jdbc:sqlserver://URAEPPDAW764:1433;DatabaseName=ARIS71;instanceName=MSSQLSERVER'

2013-10-09T15:23:50,528 ! cannot connect to SQL Server, SQL state was 08S01, error message was: The TCP/IP connection to the host URAEPPDAW764, port 1433 has failed. Error: "null. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".

2013-10-09T15:23:50,528 Launch of ARIS Lockservice failed!

2013-10-09T15:23:50,528

2013-10-09T15:23:50,528 [ There have been ERRORS, ARIS Server is going down ... ]

2013-10-09T15:23:50,528 Terminating ARIS Server ...

2013-10-09T15:23:50,528 Shutting down DB event initialisation ...

2013-10-09T15:23:50,543 Shutting down ARIS Nameservice ...

2013-10-09T15:23:50,543 Shutting down ARIS Event Service ...

2013-10-09T15:23:50,543 Shutting down ARIS Nameservice ...

2013-10-09T15:23:52,543 ARIS Server terminated!

2013-10-09T15:23:52,543

2013-10-09T15:23:52,543 [ ARIS Server is down ]

2013-10-09T15:23:52,543

 

reading this log, i understand that the change of the server name from URAEPPDAW764 to VMARIS201309 is not correctly set...

...

pam

0
by Benjamin Mueller
Posted on Thu, 10/10/2013 - 14:27

Dear pam,

changing the server name is generally not a good idea. Some services (e.g. ARIS Business Serer) are configured to connect to URAEPPDAW764. 

We re-tested the PD&A image and deployed a patch: pd&a_bugfix_1.4.1.exe (for username and password see your license email)

Therefore we recommend you to start with a new PD&A image and apply the patch. Everything should work out of the box without any problems. Just remember not to change the computer name.

Best regards,

Benjamin

_____________________________________________

Benjamin Müller

Student Employee in University Relations  

+49 6151-92-1861

benjamin.mueller@softwareag.com

www.softwareag.com

Uhlandstraße 12  |  64297 Darmstadt  |  Germany

0
by Pierre-Alain MILLET Author
Posted on Tue, 10/15/2013 - 11:10

OK, But if the server name can not be changed, that means that we can have only one VM in our network for web access.

this is then a main issue in an academic context. Because we have different cursus using ARIS and we want to separate them.

For one project, we want to clone the VM for each student group (20 groups of 6 users), because  the pedagogic objectives include project management, so the student project manager has to mmanage roles and rights using BArchitect... and then , of course, each group use it's own ARIS VM... they have to set their own report...

We do this using VMWare cloning tools and the consequence is that we have to change the computer name ...

It was possible with AEP PDA 1.3 ! Are your sure this is now forbidden ?

regards

pam

 

0
by Jonathan Nelson
Posted on Tue, 10/22/2013 - 04:14

Hi Pierre-Alain,

Am I right in assuming that your MSSQL database is called 'ARIS71' and it is running on a server called 'URAEPPDAW764'?

"2013-10-09T15:20:27,714 - using url 'jdbc:sqlserver://URAEPPDAW764:1433;DatabaseName=ARIS71;instanceName=MSSQLSERVER'
2013-10-09T15:23:50,528 ! cannot connect to SQL Server, SQL state was 08S01, error message was: The TCP/IP connection to the host URAEPPDAW764, port 1433 has failed. Error: "null. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall."."

If this is not the location of your MSSQL database you will need to update the Lockservice.cfg with the correct details.

Additionally have you downloaded the MS SQL JDBC driver (as this doesn't ship with the installer due to licensing):
http://msdn.microsoft.com/en-us/sqlserver/aa937724.aspx

I hope that helps,

Jonathan

0
by Pierre-Alain MILLET Author
Posted on Tue, 10/22/2013 - 12:43

thanks a lot, jonathan...

it's OK after fixing the Lockservice.cfg with the correct sqlserver name...

With the previous version of AEP PDA, we did not used sqlsever...

pam

 

 

0

Featured achievement

Rookie
Say hello to the ARIS Community! Personalize your community experience by following forums or tags, liking a post or uploading a profile picture.
Recent Unlocks
  • Profile picture for user frankweise
  • Profile picture for user Henrik Buckler
  • Profile picture for user UffeK
  • SS
  • MZ
  • PacMan

Leaderboard

|
Nobody has collected any points yet this week. This is your chance to become one of the top 5 on this week's leaderboard.
icon-arrow-down icon-arrow-cerulean-left icon-arrow-cerulean-right icon-arrow-down icon-arrow-left icon-arrow-right icon-arrow icon-back icon-close icon-comments icon-correct-answer icon-tick icon-download icon-facebook icon-flag icon-google-plus icon-hamburger icon-in icon-info icon-instagram icon-login-true icon-login icon-mail-notification icon-mail icon-mortarboard icon-newsletter icon-notification icon-pinterest icon-plus icon-rss icon-search icon-share icon-shield icon-snapchat icon-star icon-tutorials icon-twitter icon-universities icon-videos icon-views icon-whatsapp icon-xing icon-youtube icon-jobs icon-heart icon-heart2 aris-express bpm-glossary help-intro help-design Process_Mining_Icon help-publishing help-administration help-dashboarding help-archive help-risk icon-knowledge icon-question icon-events icon-message icon-more icon-pencil forum-icon icon-lock