Profile picture for user Dilcarina Duarte

Hello Community!

I am creating a scheduled report to save files to my computer.

When I run the report, it works fine and I can see the saved file. When the report is called by a scheduled report, the file cannot be saved, at least I can't find them on my PC.

I tried to call default reports that return a file and the behavior is the same.

(My user is a system user)

Does anyone know why this is happening?

Thanks in advance!

Regards,

Dilcarina

by André Vitor Oliveira
Posted on Thu, 12/26/2019 - 22:06

Hi Dilcarina,



You can see what's wrong with the script, when you select the scheduled script and go to 'properties' on the menu bar will open the wizard and will shows the information 'Reason for deactivation, the following errors ocurred:'  I hope this information helps you.



BR



AO 

0
by Dilcarina Duarte Author
Posted on Fri, 12/27/2019 - 11:04

Hello André!

No errors have occurred, the script can be executed and shows the last duration (always a few seconds), but cannot save the output.

My question is: How can I run and get output files when I run in other ways, but using a scheduled report, the file is not saved. Is there a way to debug a scheduled report? I tried to add a breakpoint, but nothing happens.

Regards,

Dilcarina

0
by André Vitor Oliveira
Posted on Fri, 12/27/2019 - 16:06

Hi Dilcarina,

For scheduled ARIS reports the output is stored in an internal component. This location is not accessible at file level.

The report output is then available for users via the ARIS Client and can be saved in a valid file format, e.g. .xls.

(Architect - login database - Scheduled reports - context menu of the schedule - Display result - Save in)

There is no option to debug this such of report...and let us know here if the information above helps..



BR



AO

0
by Dilcarina Duarte Author
Posted on Mon, 12/30/2019 - 10:30

Hello André!

My problem is not where the information is stored, the script is not saving files when I run a scheduled report, but it is saving when I run it manually. I think I know why. Maybe I should define a var with the appropriate path.

Regards,

Dilcarina

0

Featured achievement

Rookie
Say hello to the ARIS Community! Personalize your community experience by following forums or tags, liking a post or uploading a profile picture.
Recent Unlocks

Leaderboard

|
icon-arrow-down icon-arrow-cerulean-left icon-arrow-cerulean-right icon-arrow-down icon-arrow-left icon-arrow-right icon-arrow icon-back icon-close icon-comments icon-correct-answer icon-tick icon-download icon-facebook icon-flag icon-google-plus icon-hamburger icon-in icon-info icon-instagram icon-login-true icon-login icon-mail-notification icon-mail icon-mortarboard icon-newsletter icon-notification icon-pinterest icon-plus icon-rss icon-search icon-share icon-shield icon-snapchat icon-star icon-tutorials icon-twitter icon-universities icon-videos icon-views icon-whatsapp icon-xing icon-youtube icon-jobs icon-heart icon-heart2 aris-express bpm-glossary help-intro help-design Process_Mining_Icon help-publishing help-administration help-dashboarding help-archive help-risk icon-knowledge icon-question icon-events icon-message icon-more icon-pencil forum-icon