Dear community,

(I hope this is the right forum, apologies if it isn't)

I have installed ARIS PPM as per the installation manual, added the licenses and am now trying to run ARIS PPM Customizing Toolkit 10.4 from the windows start menu (I've also tried manually running the .bat file it points to, and tried running both as administrator explicitly). It outputs an error and then closes immediatly after. I've enabled echoing in various files to get the following output, it runs this command right before the crash:

<code>C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\bin>"C:\SoftwareAG\ppm\server\jre\bin\java.exe" -DprovisioningEnabled=true -Xmx1024m -classpath "";"C:\SoftwareAG\ppm\server\bin\work\data_ppm\config";"C:\SoftwareAG\ppm\server\bin\work\data_ppm\system\provisioning";"C:\SoftwareAG\ppm\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\config";"C:\SoftwareAG\ppm\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\config";"C:\SoftwareAG\ppm\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\dtd";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\ppmctklib\ppmpatch.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\ppmctklib\ppmspatch.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\lib\ppmbasecfg.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\lib\ppmbasecfgprops.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\lib\ppmcfg.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\lib\ppmcfgprops.jar";"C:\SoftwareAG\PPM\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm\ctk\ctk\lib\ppmloader.jar" -Djava.rmi.server.RMIClassLoaderSpi=default -Dsetupbase.logdir="C:\SoftwareAG\ppm\server\bin\work\data_ppm\system\log" -Dzkc.working.dir="C:\SoftwareAG\ppm\server\bin\work\data_ppm\system\provisioning" -DPPM5_HOME="" -DPPM9_HOME="C:\SoftwareAG\ppm\server\bin\agentLocalRepo\.unpacked\20190529.101741_ppm-client-run-prod-10.4.0.0-runnable.zip\ppm" -DPPM9_DATA=C:\SoftwareAG\ppm\server\bin\work\data_ppm -DPPM9_CTK_CLASSPATH="" com.idsscheer.ppm.configurator.main.ZCTKGui</code>

And then results in the following error message:

<code>Exception in thread "AWT-EventQueue-0" java.lang.ExceptionInInitializerError
        at com.idsscheer.ppm.configurator.main.ZCTKGui.runGui(ZCTKGui.java:540)
        at com.idsscheer.ppm.configurator.main.ZCTKGui.lambda$main$0(ZCTKGui.java:528)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
        at java.awt.EventQueue.access$500(EventQueue.java:97)
        at java.awt.EventQueue$3.run(EventQueue.java:709)
        at java.awt.EventQueue$3.run(EventQueue.java:703)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.ArrayIndexOutOfBoundsException: bad width and/or height
        at sun.awt.windows.WCustomCursor.createCursorIndirect(Native Method)
        at sun.awt.windows.WCustomCursor.createNativeCursor(WCustomCursor.java:84)
        at sun.awt.CustomCursor.<init>(CustomCursor.java:98)
        at sun.awt.windows.WCustomCursor.<init>(WCustomCursor.java:45)
        at sun.awt.windows.WToolkit.createCustomCursor(WToolkit.java:810)
        at com.idsscheer.ppm.client.gui.plaf.ZPPMLookAndFeel.<clinit>(ZPPMLookAndFeel.java:37)</code>

So it looks to me like it's trying to create a custom cursor, fails and then quits. I don't have the slightest clue why this happens however, or how to solve it.

Additional info: the host machine is a windows 10, version 1803 build 17134.765, the ARIS PPM installation is of the smallest / demo type and version 10.4.

Please let me know if there is any further information that might help and thanks in advance,

Joris

Tags: ARIS PPM